Bluetooth PAN (Personal Area Network) on Fedora 8 – part1[failed]

Well, after try Bluetooth PAN on Windows success… now I’m trying Bluetooth PAN on Fedora 8…
And what I’ve got ? It’s failed…

Here’s my bluez version:
[root@laptop ~]# rpm -qf /usr/bin/pand
error: file /usr/bin/pand: No such file or directory
[root@laptop ~]# rpm -qa|grep bluez
bluez-libs-devel-3.35-1.fc8
bluez-utils-3.35-5.fc8
bluez-utils-cups-3.35-5.fc8
bluez-hcidump-1.40-1.fc8
bluez-libs-3.35-1.fc8
bluez-utils-gstreamer-3.35-5.fc8
bluez-gnome-analyzer-0.14-8.fc8
bluez-utils-alsa-3.35-5.fc8
bluez-gnome-0.14-8.fc8

I’ve tired search on Google and I think it’s a bugs or what?

After reading any articles, like this one, to get Bluetooth PAN work I must run pand
[root@laptop ~]# cat /etc/init.d/pand|grep daemon
daemon /usr/bin/pand $PANDARGS
[root@laptop ~]# cat /etc/rc.d/init.d/pand|grep daemon
daemon /usr/bin/pand $PANDARGS
[root@laptop ~]# find /sbin/ -iname 'pand'
[root@laptop ~]# find /bin/ -iname 'pand'
[root@laptop ~]# find /usr/ -iname 'pand'
[root@laptop ~]# sdptool add NAP
[root@laptop ~]# cat /etc/sysconfig/pand
PANDARGS='--listen --role NAP'
#PANDARGS='--search --cache --persist'
[root@laptop ~]# cat /var/lib/bluetooth/0x:xF:x2:Ex:4x:x4/nap
name BlueZ NAP service
enabled 1


[root@laptop ~]# vim /etc/sysconfig/network-scripts/ifcfg-bnep0
---------------------------------------------------------------
DEVICE=bnep0
ONBOOT=no
BOOTPROTO=no
IPADDR=192.168.0.1
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
---------------------------------------------------------------
[root@laptop ~]# /etc/init.d/bluetooth restart
Stopping Bluetooth services: [ OK ]
Starting Bluetooth services: [ OK ]
[root@laptop ~]# hciconfig -a
hci0: Type: USB
BD Address: 0x:xF:x2:Ex:4x:x4 ACL MTU: 1017:8 SCO MTU: 64:8
UP RUNNING PSCAN ISCAN
RX bytes:1249 acl:0 sco:0 events:30 errors:0
TX bytes:366 acl:0 sco:0 commands:30 errors:0
Features: 0xff 0xff 0x8f 0xfe 0x9b 0xf9 0x00 0x80
Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
Link policy: RSWITCH HOLD SNIFF PARK
Link mode: MASTER
Name: 'laptop-0'
Class: 0x0a010c
Service Classes: Networking, Capturing
Device Class: Computer, Laptop
HCI Ver: 2.0 (0x3) HCI Rev: 0x212c LMP Ver: 2.0 (0x3) LMP Subver: 0x41d3
Manufacturer: Broadcom Corporation (15)

[root@laptop ~]# pand
-bash: pand: command not found
[root@laptop ~]# ifup bnep0
Unknown BNEP mode :


Soo what happen in Fedora ??? Is this feature not support anymore on bluez ???

Reference :
http://www.google.com/search?q=pand+on+fedora
https://bugzilla.redhat.com/show_bug.cgi?id=462183

One Comment

  1. Posted 2 January 2010 at 11:57 | Permalink

    Thankz for the information.


Post a Comment

Required fields are marked *

*
*

%d bloggers like this: